OESIS Framework Jul 26, 2022 Release

Product Overview

OESIS Framework is a cross-platform, versatile and modular framework that enables software engineers and technology vendors to build advanced endpoint security products.

Anti-Keylogger Module Updates

    Internal fixes and optimizations

Anti-Screen Capture Module Updates

    Internal fixes and optimizations

Vulnerability Module Updates

    CVE-2022-34232

    • Vendor: Adobe Systems Inc.
    • Affected products: Adobe Acrobat DC Continuous, Adobe Acrobat Reader DC Classic 2017, Adobe Acrobat DC Classic 2017, Adobe Acrobat DC Classic 2020, Adobe Acrobat Reader DC Classic 2020, Adobe Acrobat Reader DC Continuous
    • Score:
    • Affected versions: 22.001.20142 and prior

    CVE-2022-32213

    • Vendor: Joyent, Inc.
    • Affected products: Node.js Current, Node.js, Node.js LTS
    • Score:
    • Affected versions: 18.4.999999.999998 and prior

    CVE-2022-32223

    • Vendor: Joyent, Inc.
    • Affected products: Node.js LTS, Node.js Current
    • Score:
    • Affected versions: 16.19.999999.999998 and prior

    CVE-2022-34236

    • Vendor: Adobe Systems Inc.
    • Affected products: Adobe Acrobat Reader DC Continuous, Adobe Acrobat Reader DC Classic 2017, Adobe Acrobat DC Classic 2017, Adobe Acrobat DC Classic 2020, Adobe Acrobat Reader DC Classic 2020, Adobe Acrobat DC Continuous
    • Score:
    • Affected versions: 22.001.20142 and prior

    CVE-2022-34237

    • Vendor: Adobe Systems Inc.
    • Affected products: Adobe Acrobat DC Classic 2020, Adobe Acrobat Reader DC Classic 2020, Adobe Acrobat DC Continuous, Adobe Acrobat Reader DC Continuous, Adobe Acrobat DC Classic 2017, Adobe Acrobat Reader DC Classic 2017
    • Score:
    • Affected versions: 20.005.30331 and prior

    CVE-2022-34217

    • Vendor: Adobe Systems Inc.
    • Affected products: Adobe Acrobat DC Classic 2020, Adobe Acrobat Reader DC Classic 2017, Adobe Acrobat DC Classic 2017, Adobe Acrobat Reader DC Continuous, Adobe Acrobat DC Continuous, Adobe Acrobat Reader DC Classic 2020
    • Score:
    • Affected versions: 20.005.30331 and prior

    CVE-2022-34874

    • Vendor: Foxit Software
    • Affected products: Foxit Reader
    • Score:
    • Affected versions: 11.2.2.53575 and prior

    CVE-2022-34222

    • Vendor: Adobe Systems Inc.
    • Affected products: Adobe Acrobat DC Classic 2020, Adobe Acrobat DC Classic 2017, Adobe Acrobat Reader DC Classic 2017, Adobe Acrobat DC Continuous, Adobe Acrobat Reader DC Continuous, Adobe Acrobat Reader DC Classic 2020
    • Score:
    • Affected versions: 20.005.30331 and prior

    CVE-2022-34233

    • Vendor: Adobe Systems Inc.
    • Affected products: Adobe Acrobat Reader DC Classic 2017, Adobe Acrobat DC Classic 2017, Adobe Acrobat Reader DC Continuous, Adobe Acrobat DC Classic 2020, Adobe Acrobat DC Continuous, Adobe Acrobat Reader DC Classic 2020
    • Score:
    • Affected versions: 17.012.30227 and prior

    CVE-2022-34215

    • Vendor: Adobe Systems Inc.
    • Affected products: Adobe Acrobat Reader DC Classic 2017, Adobe Acrobat Reader DC Continuous, Adobe Acrobat DC Classic 2020, Adobe Acrobat Reader DC Classic 2020, Adobe Acrobat DC Classic 2017, Adobe Acrobat DC Continuous
    • Score:
    • Affected versions: 17.012.30227 and prior

    CVE-2022-28679

    • Vendor: Foxit Software
    • Affected products: Foxit Reader
    • Score:
    • Affected versions: 11.2.1.53537 and prior

    CVE-2022-34220

    • Vendor: Adobe Systems Inc.
    • Affected products: Adobe Acrobat Reader DC Classic 2017, Adobe Acrobat Reader DC Continuous, Adobe Acrobat DC Classic 2017, Adobe Acrobat DC Continuous, Adobe Acrobat Reader DC Classic 2020, Adobe Acrobat DC Classic 2020
    • Score:
    • Affected versions: 17.012.30227 and prior

    CVE-2022-28678

    • Vendor: Foxit Software
    • Affected products: Foxit Reader
    • Score:
    • Affected versions: 11.2.1.53537 and prior

    CVE-2022-34239

    • Vendor: Adobe Systems Inc.
    • Affected products: Adobe Acrobat Reader DC Classic 2020, Adobe Acrobat DC Classic 2017, Adobe Acrobat DC Continuous, Adobe Acrobat Reader DC Classic 2017, Adobe Acrobat Reader DC Continuous, Adobe Acrobat DC Classic 2020
    • Score:
    • Affected versions: 20.005.30331 and prior

    CVE-2021-34987

    • Vendor: Parallels, Inc.
    • Affected products: Parallels Desktop
    • Score:
    • Affected versions: 16.5.1 and prior

    CVE-2020-23563

    • Vendor: Irfan Skiljan
    • Affected products: IrfanView
    • Score:
    • Affected versions: 4.54 and prior

    CVE-2022-34219

    • Vendor: Adobe Systems Inc.
    • Affected products: Adobe Acrobat DC Classic 2020, Adobe Acrobat Reader DC Classic 2017, Adobe Acrobat DC Continuous, Adobe Acrobat DC Classic 2017, Adobe Acrobat Reader DC Classic 2020, Adobe Acrobat Reader DC Continuous
    • Score:
    • Affected versions: 20.005.30331 and prior

    CVE-2022-34230

    • Vendor: Adobe Systems Inc.
    • Affected products: Adobe Acrobat DC Continuous, Adobe Acrobat Reader DC Classic 2017, Adobe Acrobat Reader DC Classic 2020, Adobe Acrobat DC Classic 2017, Adobe Acrobat DC Classic 2020, Adobe Acrobat Reader DC Continuous
    • Score:
    • Affected versions: 22.001.20142 and prior

    CVE-2022-28669

    • Vendor: Foxit Software
    • Affected products: Foxit Reader
    • Score:
    • Affected versions: 11.2.1.53537 and prior

    CVE-2022-28672

    • Vendor: Foxit Software
    • Affected products: Foxit Reader
    • Score:
    • Affected versions: 11.2.1.53537 and prior

    CVE-2022-34226

    • Vendor: Adobe Systems Inc.
    • Affected products: Adobe Acrobat DC Continuous, Adobe Acrobat DC Classic 2020, Adobe Acrobat Reader DC Classic 2017, Adobe Acrobat DC Classic 2017, Adobe Acrobat Reader DC Classic 2020, Adobe Acrobat Reader DC Continuous
    • Score:
    • Affected versions: 22.001.20142 and prior

    CVE-2022-34221

    • Vendor: Adobe Systems Inc.
    • Affected products: Adobe Acrobat Reader DC Classic 2020, Adobe Acrobat DC Classic 2020, Adobe Acrobat DC Classic 2017, Adobe Acrobat Reader DC Classic 2017, Adobe Acrobat DC Continuous, Adobe Acrobat Reader DC Continuous
    • Score:
    • Affected versions: 20.005.30331 and prior

    CVE-2022-21540

    • Vendor: Oracle Corporation
    • Affected products: Java SE Development Kit, Java
    • Score:
    • Affected versions: 18.0.1.1.0 and prior

    CVE-2022-28671

    • Vendor: Foxit Software
    • Affected products: Foxit Reader
    • Score:
    • Affected versions: 11.2.1.53537 and prior

    CVE-2022-34225

    • Vendor: Adobe Systems Inc.
    • Affected products: Adobe Acrobat Reader DC Classic 2017, Adobe Acrobat Reader DC Continuous, Adobe Acrobat DC Classic 2020, Adobe Acrobat DC Continuous, Adobe Acrobat DC Classic 2017, Adobe Acrobat Reader DC Classic 2020
    • Score:
    • Affected versions: 17.012.30227 and prior

    CVE-2022-28675

    • Vendor: Foxit Software
    • Affected products: Foxit Reader
    • Score:
    • Affected versions: 11.2.1.53537 and prior

    CVE-2022-34234

    • Vendor: Adobe Systems Inc.
    • Affected products: Adobe Acrobat DC Classic 2020, Adobe Acrobat Reader DC Classic 2020, Adobe Acrobat Reader DC Continuous, Adobe Acrobat DC Continuous, Adobe Acrobat DC Classic 2017, Adobe Acrobat Reader DC Classic 2017
    • Score:
    • Affected versions: 20.005.30331 and prior

    CVE-2022-28683

    • Vendor: Foxit Software
    • Affected products: Foxit Reader
    • Score:
    • Affected versions: 11.2.1.53537 and prior

    CVE-2022-34248

    • Vendor: Adobe Systems Inc.
    • Affected products: Adobe InDesign
    • Score:
    • Affected versions: 17.2.1 and prior

    CVE-2017-3244

    • Vendor: Oracle Corporation
    • Affected products: MySQL Server
    • Score: 4.0
    • Affected versions: 5.7.16 and prior

    CVE-2022-34223

    • Vendor: Adobe Systems Inc.
    • Affected products: Adobe Acrobat DC Continuous, Adobe Acrobat Reader DC Classic 2017, Adobe Acrobat Reader DC Classic 2020, Adobe Acrobat DC Classic 2017, Adobe Acrobat DC Classic 2020, Adobe Acrobat Reader DC Continuous
    • Score:
    • Affected versions: 22.001.20142 and prior

    CVE-2022-34246

    • Vendor: Adobe Systems Inc.
    • Affected products: Adobe InDesign
    • Score:
    • Affected versions: 17.2.1 and prior

    CVE-2022-28682

    • Vendor: Foxit Software
    • Affected products: Foxit Reader
    • Score:
    • Affected versions: 11.2.1.53537 and prior

    CVE-2022-32212

    • Vendor: Joyent, Inc.
    • Affected products: Node.js Current, Node.js, Node.js LTS
    • Score:
    • Affected versions: 18.4.999999.999998 and prior

    CVE-2022-34216

    • Vendor: Adobe Systems Inc.
    • Affected products: Adobe Acrobat Reader DC Classic 2020, Adobe Acrobat DC Classic 2017, Adobe Acrobat DC Classic 2020, Adobe Acrobat DC Continuous, Adobe Acrobat Reader DC Continuous, Adobe Acrobat Reader DC Classic 2017
    • Score:
    • Affected versions: 20.005.30331 and prior

    CVE-2022-32222

    • Vendor: Joyent, Inc.
    • Affected products: Node.js LTS, Node.js, Node.js Current
    • Score:
    • Affected versions: 18.4.999999.999998 and prior

    CVE-2020-9951

    • Vendor: Apple Inc.
    • Affected products: iOS, Safari, iTunes, iCloud
    • Score: 6.8
    • Affected versions: 13.999999.999998 and prior

    CVE-2017-3238

    • Vendor: Oracle Corporation
    • Affected products: MySQL Server
    • Score: 4.0
    • Affected versions: 5.7.16 and prior

    CVE-2022-34228

    • Vendor: Adobe Systems Inc.
    • Affected products: Adobe Acrobat DC Classic 2020, Adobe Acrobat DC Classic 2017, Adobe Acrobat DC Continuous, Adobe Acrobat Reader DC Classic 2020, Adobe Acrobat Reader DC Classic 2017, Adobe Acrobat Reader DC Continuous
    • Score:
    • Affected versions: 20.005.30331 and prior

    CVE-2022-28677

    • Vendor: Foxit Software
    • Affected products: Foxit Reader
    • Score:
    • Affected versions: 11.2.1.53537 and prior

    CVE-2022-34243

    • Vendor: Adobe Systems Inc.
    • Affected products: Adobe Photoshop
    • Score:
    • Affected versions: 23.3.2 and prior

    CVE-2022-32215

    • Vendor: Joyent, Inc.
    • Affected products: Node.js Current, Node.js LTS, Node.js
    • Score:
    • Affected versions: 18.4.999999.999998 and prior

    CVE-2020-10930

    • Vendor: NetGear
    • Affected products: R6700 Nighthawk AC1750 Smart WiFi Dual Band Gigabit Router
    • Score: 3.3
    • Affected versions: 1.0.4.84 10.0.58 and prior

    CVE-2022-34229

    • Vendor: Adobe Systems Inc.
    • Affected products: Adobe Acrobat DC Classic 2020, Adobe Acrobat Reader DC Classic 2017, Adobe Acrobat Reader DC Classic 2020, Adobe Acrobat DC Continuous, Adobe Acrobat DC Classic 2017, Adobe Acrobat Reader DC Continuous
    • Score:
    • Affected versions: 20.005.30331 and prior

    CVE-2022-28670

    • Vendor: Foxit Software
    • Affected products: Foxit Reader
    • Score:
    • Affected versions: 11.2.1.53537 and prior

    CVE-2022-28673

    • Vendor: Foxit Software
    • Affected products: Foxit Reader
    • Score:
    • Affected versions: 11.2.1.53537 and prior

    CVE-2007-0455

    • Vendor: The PHP Group
    • Affected products: PHP
    • Score: 7.5
    • Affected versions: 4.4.6.999998 and prior

    CVE-2020-9952

    • Vendor: Apple Inc.
    • Affected products: Safari, iOS, iCloud
    • Score: 5.8
    • Affected versions: 13.999999.999998 and prior

    CVE-2022-21541

    • Vendor: Oracle Corporation
    • Affected products: Java SE Development Kit, Java
    • Score:
    • Affected versions: 18.0.1.1.0 and prior

    CVE-2022-28674

    • Vendor: Foxit Software
    • Affected products: Foxit Reader
    • Score:
    • Affected versions: 11.2.1.53537 and prior

    CVE-2022-34245

    • Vendor: Adobe Systems Inc.
    • Affected products: Adobe InDesign
    • Score:
    • Affected versions: 17.2.1 and prior

    CVE-2021-41031

    • Vendor: Fortinet Inc.
    • Affected products: FortiClient
    • Score:
    • Affected versions: 7.0.2 and prior

    CVE-2021-34986

    • Vendor: Parallels, Inc.
    • Affected products: Parallels Desktop
    • Score:
    • Affected versions: 16.5.0 and prior

    CVE-2022-34247

    • Vendor: Adobe Systems Inc.
    • Affected products: Adobe InDesign
    • Score:
    • Affected versions: 17.2.1 and prior

    CVE-2020-9948

    • Vendor: Apple Inc.
    • Affected products: Safari
    • Score: 6.8
    • Affected versions: 13.999999.999998 and prior

    CVE-2022-34244

    • Vendor: Adobe Systems Inc.
    • Affected products: Adobe Photoshop
    • Score:
    • Affected versions: 23.3.2 and prior

    CVE-2022-32214

    • Vendor: Joyent, Inc.
    • Affected products: Node.js Current, Node.js, Node.js LTS
    • Score:
    • Affected versions: 18.4.999999.999998 and prior

    CVE-2022-34873

    • Vendor: Foxit Software
    • Affected products: Foxit Reader
    • Score:
    • Affected versions: 11.2.2.53575 and prior

    CVE-2017-10384

    • Vendor: Oracle Corporation
    • Affected products: MySQL Server
    • Score: 4.0
    • Affected versions: 5.7.19 and prior

    CVE-2022-28681

    • Vendor: Foxit Software
    • Affected products: Foxit Reader
    • Score:
    • Affected versions: 11.2.1.53537 and prior

    CVE-2022-28676

    • Vendor: Foxit Software
    • Affected products: Foxit Reader
    • Score:
    • Affected versions: 11.2.1.53537 and prior

    CVE-2007-1887

    • Vendor: The PHP Group
    • Affected products: PHP
    • Score: 7.5
    • Affected versions: 5.2.2.999998 and prior

    CVE-2022-34875

    • Vendor: Foxit Software
    • Affected products: Foxit Reader
    • Score:
    • Affected versions: 11.2.2.53575 and prior

Patch Management Module

    Internal fixes and optimizations

AppRemover Module Updates

    Internal fixes and optimizations

Removable Media Protection Module Updates

Windows

    Internal fixes and optimizations

Mac

    Internal fixes and optimizations

Advanced Malware Detection Module Updates

Windows

    Internal fixes and optimizations

Mac

    Internal fixes and optimizations

Device Compliance Module Updates

Windows

SDK updates:

    Internal fixes and optimizations

Products updates:

    Internal fixes and optimizations

Products support:

    Added Tested Point 86.50.0190 for Check Point Endpoint Security

    • Vendor: Check Point Software Technologies
    • Product: Check Point Endpoint Security

    Added Tested Point 4.10.1 for RAV Endpoint Protection

    • Vendor: Reason Software Company Inc.
    • Product: RAV Endpoint Protection

    Added Tested Point 15.2.11.0 for ESET NOD32 Antivirus

    • Vendor: ESET
    • Product: ESET NOD32 Antivirus

    Added Tested Point 9.1.2051.0 for ESET Endpoint Security

    • Vendor: ESET
    • Product: ESET Endpoint Security

    Added Tested Point 86.25.5060 for Check Point Endpoint Security

    • Vendor: Check Point Software Technologies
    • Product: Check Point Endpoint Security

macOS

SDK updates:

    Internal fixes and optimizations

Products updates:

    Internal fixes and optimizations

Products support:

    Added Tested Point 12.6.3 for Dr.Web for MacOS

    • Vendor: Doctor Web, Ltd.
    • Product: Dr.Web for MacOS

Linux

SDK updates:

    Internal fixes and optimizations

Products updates:

    Internal fixes and optimizations

Products support:

    Added Tested Point 15.6.74.0 for OPSWAT Client

    • Vendor: OPSWAT, Inc.
    • Product: OPSWAT Client

    Added Tested Point 15.4.77.0 for OPSWAT Client

    • Vendor: OPSWAT, Inc.
    • Product: OPSWAT Client

Release Details

Sign up for Blog updates
Get information and insight from the leaders in advanced threat prevention.